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Programming an Embedded
MicroBlaze Processor (XD131)

Important
Released with AMD Vitis™ Unified Software Platform and AMD Vivado™ Design

Suite 2025.1 without changes from 2024 .1.
Create an AMD MicroBlaze™ system for a Spartan-7 FPGA using Vivado IP

integrator.
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Programming an Embedded MicroBlaze
Processor

In this tutorial, you will create a simple AMD soft-processor system for a Spartan-7
FPGA using AMD Vivado™ [P integrator.
This tutorial uses the classic AMD MicroBlaze™ soft-processor.

Introduction

The MicroBlaze system includes native AMD IP including:

» MicroBlaze processor

o AXI block RAM

e Double Data Rate 3 (DDR3) memory
« UARTLIite

« AXI GPIO

e MicroBlaze Debug Module (MDM)

e Proc Sys Reset

e Local memory bus (LMB)

Parts of the block design are constructed using the Platform Board Flow feature.
This lab also shows the cross-trigger capability of the MicroBlaze processor.
The feature is demonstrated using a software application code developed in the
Vitis software platform in a stand-alone application mode.

This lab targets the AMD SP701 FPGA Evaluation Kit.

Step 1: Start the Vivado IDE and Create a Project

1. Start the Vivado IDE by clicking the Vivado desktop icon or by typing vivado
at a command prompt.

2. From the Quick Start page, select Create Project.

3. In the New Project dialog box, use the following settings:
a. In the Project Name dialog box, type the project name and location.
b. Make sure that the Create project subdirectory check box is selected.
Click Next.
c. In the Project Type dialog box, select RTL project. Ensure that the Do not
specify sources at this time check box is cleared. Click Next.
d. In the Add Sources dialog box, set the Target language to either VHDL or
Verilog. You can leave the Simulator language selection to Mixed.
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e. Click Next.

f. In Add Constraints dialog box, click Next.

g. In the Default Part dialog box, select Boards and choose Spartan-7 SP701
Evaluation Platform. Click Next.

h. Review the project summary in the New Project Summary dialog box and
click Finish to create the project.

Because you selected the SP701 board when you created the Vivado IDE project,
you see the following message in the Tcl Console:

set_property board_part xilinx.com:sp701:part@:1.1 [current_project]

Although Tcl commands are available for many of the actions performed in the
Vivado IDE, they are not explained in this tutorial. Instead, a Tcl script is provided
that can be used to recreate this entire project. See the Tcl Console for more
information. You can also refer to the Vivado Design Suite Tcl Command Reference
Guide (UG835) for information about the write bd tcl commands.

Step 2: Create an IP Integrator Design

1.
2.

From Flow Navigator, under IP integrator, select Create Block Design.
Specify the IP subsystem design name. For this step, you can use
mb_subsystem as the Design name. Leave the Directory field set to its default
value of <Local to Project>. Leave the Specify source set drop-down list set to
its default value of Design Sources.

. Click OK in the Create Block Design dialog box, shown in the following figure.

Create Block Design [ E
Please specify name of block design, .
Pu
Design name: mb_subsystem
Directory: s <Llocal to Project= w
Specify source set: Design Sources w

4. In the IP integrator diagram area, right-click and select Add IP.

The IP integrator Catalog opens. Alternatively, you can also select the Add IP
icon in the middle of the canvas.

+
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5. Type mig in the Search field to find the MIG core, then select Memory
Interface Generator (MIG 7 Series), and press Enter.

Search: mid (1 match)

Memory Interface Generator (MIG 7 Series)

EMTER to select, ESC to cancel, Ctrl+Q for IP details

The Designer Assistance link becomes active in the block design banner.
6. Click Run Block Automation.

Diagram 200 X
(€] HE O Q + E » C g Default View v o

* Designer Assistance available. Run Block Autornation Run Connection Automation

mig_7series_0

||+ ek rer
sys_rst

Memory Interface Generator (MIG 7 Series)

The Run Block Automation dialog box opens.
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Run Block Automation *

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the leftto display its configuration options on the right.

Q - -
= -

~ [+ All Automation (1 out of 1 selected)

Description

o Connect Board Part Interface to MIG IP.
|| - mig_7series_D
Instance: /mig_7series_0

Options

Board_Part_Interface:  ddr3_sdram

(2)

7. Click OK. This instantiates the MIG core and connects the I/O interfaces to the
I/O interfaces for the DDR memory on the SP701 board.

mig_7series_0

DDR3 + ||l=—="> ddr3_sdram

4+ S_AXI ui_clk_sync_rst =
sys_diff_ clock [m|| + sys_cik ui_clk =
4 sys_rst ui_addn_clk 0 =
4 aresetn mmeom_locked =

init_calib_complete =—

Memory Interface Generator (MIG 7 Series)

8. Right-click anywhere in the block design canvas, and select Add IP. The IP
catalog opens.

9. In the Search field, type micr to find the MicroBlaze IP, then select
MicroBlaze, and press Enter.
Note: If not displayed by default, the IP Details window can be displayed by
clicking CTRL+Q on the keyboard while searching for IP.
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Search: micr (6 matches)

MicroBlaze

MicroBlaze Debug Madule (MDI)
MicroBlaze Debug Madule (MDM) Y
MicroBlaze MCS

MicroBlaze MCS 'V

MicroBlaze V

EMTER to select, ESC to cancel, Ctrl+Q for IP details
IP Details b4

Mame: MicroBlaze
Yersion: (Rev. ")
Interfaces:  AXld, AXI4-Stream

Description: The MicroBlaze 32 and 64 bit soft processor core, providing
an instruction set optimized for embedded applications with
many user-configurable options. MicroBlaze has many
advanced architecture features like Instruction and Data-side
cache with AXl interfaces, Floating-Point unit (FPL), Memory
Management Unit (MMU}), and fault tolerance support. It is
highly recommended to create MicroBlaze systems within
Wivado IP Integrator, to enable export to the Xiling Software
Development Kit (SDK) for software development. “

Use the Board Window to Connect to Board Interfaces

There are several ways to use an existing interface in IP integrator. Use the Board
window to instantiate some of the interfaces that are present on the SP701 board.

1. Navigate to the Windows>Board.
2. Select the Board window to see the interfaces present on the SP701 board.
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Board ?T 08X
Q = & w
I8 Spartan-7 SPT01 Evaluation Platform
~ = Clock Sources (0 out of 1 connected
O System differential clock
Ethernet Configurations (0 out of 2 connected
2 Onboard PHY 1
*2 Onboard PHY 2
External Memory (1 out of 2 connected
*8 DDR3 SDRAM
¥ 5P flash
General Purpose Input or Output (0 out of 3 conne
2 DIP switches
¥JLED

¥ Push buttons

v [= Miscellaneous (0 out of 2 connected
¥ I
¥ UART

~ = Pmod (0 out of 6 connected)

*2 Connector PMODN
2 Connector PMOD2
2 Connector PMOD3
*2 Connector PMOD4
2 Connector PMODS
¥ Connector PMODE
Reset (0 out of 1 connected
O FPGA Reset
£ >

In the Board window, notice that the DDR3 SDRAM interface is connected as
shown by the circle ™ in the following figure. This is because you used the
Block Automation feature in the previous steps to connect the MIG core to the
board interfaces for DDR3 SDRAM memory.
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Board ? O a1 X
Q = & w
I8 Spartan-7 SPT01 Evaluation Platform
Clock Sources
» System differential clock

Ethernet Configurations

2 Onboard PHY 1

¥ Onboard PHY 2
External Memory (1

* DDR3 SDRAM

%3 SP| flash
General Purpose Input or Qutput

%2 DIP switches

KJLED

2 Push buttons e

3. From the Board window, select UART under the Miscellaneous folder, and
drag and drop it into the block design canvas.
This instantiates the AXI Uartlite IP on the block design.

4. From the Board window, select LED under the General Purpose Input or
Output folder, and drag and drop it into the block design canvas.
This instantiates the GPIO IP on the block design and connects it to the on-
board LEDs.

5. Next, from the Board window, select FPGA Reset under the Reset folder, and
drag and drop it into the block design canvas.
This connects the CPU push button reset to the MIG core IP.

Displayed in the footer
Page 11 of 75



Programming an Embedded MicroBlaze Processor (XD131)

The block design now should look like the following figure.

MicroBlaze

sys_diff_clock [

=+ san
s i
s i

el ddr3 sdram

=k
interrupt =

rs232 uart
eetn -

AXI Uartlite

mig_Tseries 0

reset [T

Diagram ?_0ax
a g i & <o Q + B #, C o | = DefaultView ~ k-3
P Designer Assistance available. Run Block Automation

i ani_gpio_ 0
microblaze 0 o+ sm |
I+ mrennuer L @0 + ||l Ied_8bits
I+ oesue . =r o +| S smen
-k MICTOB'&ZB e + | h AXI GPIO
0= axi_uartlite_ 0

Add Peripheral: AXI| block RAM Controller

1. Add the AXI block RAM Controller, shown in the following figure, by right-
clicking the IP integrator canvas and selecting Add IP.
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Search: | 2 axi bram (1 match)

T AX1 BRAM Controller

ENTER to select, ESC to cancel, Ctrl+Q for IP details

IP Details x
Lt
Mame: AXI BRAM Controller
Version: (Rev. )
Interfaces:  AXl4
Description: The AXl Block RAM (BRAM) Controller is a soft IP core. The

core is designed as an AXl Endpoint slave IP for
integration with the AXl interconnect and system master
devices to communicate to local block RAM. The core
supports both single and burst transactions to the block

RAM and is optimized for peformance.
W

The block design now should look like the following figure.

-
s o _dock O E I

Diagram
Q@ o & © Q + E #* C o = DefaultView W
* Desig we available. Run Block Automation  Run Connection Automation

i bwam et 0

--“‘f‘ s ]
e s ponm |||
P

AT B
axi_gpic 0

microblaze 0 ¢ L0

I wrermen _ :,:::“__ o -+
JE- MicroBlaze® il ..

[l e iits

ani yartite 0

] o

WcroB
L 10 debid sem

st [T oy

?

- 0ax

Run Block Automation
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1. Click Run Block Automation, as shown below.

Address Editor Address Map Diagram
@ g = = © Q + E 2 C o Default View v

» Designer Assistance available. Run Block Automation Run Connection Automation

The Run Block Automation dialog box opens.
2. On the Run Block Automation dialog box:
a. Leave Preset as the default value, None.
b. Set Local Memory to 64 KB.
c. Leave the Local Memory ECC as the default value, None.
d. Set Cache Configuration to 32 KB.
e. Set Debug Module to Extended Debug.
f. Leave the Peripheral AXI Port option as the default value, Enabled.
g. Leave the Interrupt Controller option unchecked.
h. Leave The Clock source option set to /mig_7series_0/ui_addn_clk_0 (100
MHz).

Run Block Automation x

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the leftto display its configuration options on the right.

Q - -
= =

~ [v] All Automation (1 out of 1 selected)

Description

. MicroBlaze connection automation generates local memory of selected size, and caches can be configured
[/ microblaze_0 MicroBlaze Debug Module, Peripheral Al Interconnect, Interrupt Controller, a clock source, Processor System Reset
are added and connected as needed. A preset MicroBlaze configuration can also be selected.

Information about the options can be found in the tooltips.

Options
Preset MNone v
Local Memaory 64KB w
Local Memory ECC Mone ~
Cache Configuration 32KB “
Debug Module Extended Debug
Peripheral AXI Port Enabled ~

(") Interrupt Controller

Clock Connection Imig_7series_0Mi_addn_clk_0 (100 MHz)  w

|/7\|
(2) oK Cancel

3. Click OK.
This generates a basic MicroBlaze system in the IP integrator diagram area,
as shown in the following figure.
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# Designer Assistance available. Run Connection Automation

[+ wrerset o
T2 MicroBlaze ™ s

et

£ dde3_sdram

sys_it ook [Dmmm| |+ 55 c1
resat
660 1+ [ t0d_Bbs

4. Click Run Block Automation again.

The Run Block Automation dialog box opens.
5. On the Run Block Automation dialog box:

a. Set Keep Classic MicroBlaze

Run Block Automation

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its configuration options on the right.

Q - -
= -

~ [ All Automation (1 out of 1 selected)

Description

S MicroBlaze conversion automation convers classic MicroBlaze processors to the RISC-V MicroBlaze V processor. The
[+ microblaze_0 corresponding MicroBlaze Debug Module (MDM) is also converted

Conversion is not available due to features currently not supported in RISC-V:

« MDM Cross Trigger

Options

) Keep Classic MicroBlaze

(?)
\?) OK Cancel

With the introduction of the MicroBlaze V, AMD provide the ability to automate
the convertion of a classic MicroBlaze processors to the RISC-V MicroBlaze V
processor. In this tutorial, the classic MicroBlaze is kept.

Use Connection Automation

Run Connection Automation provides several options that you can select to make
connections. This section will walk you through the first connection, and then you
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will use the same procedure to make the rest of the required connections for this
tutorial.

1. Click Run Connection Automation as shown in the following figure.

Diagram
@ Q9 u O Q s +
* Designer Assistance available. Run Connection Automation

The Run Connection Automation dialog box opens.

2. Check the All Automation check box in the left pane of the dialog box as
shown in the following figure. This selects interfaces to run Connection
Automation for.

Run Connection Automation X

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its configuration options on
the right.

I4

Q

e

-
=

| Al Automation (9 out of 9 selected)

®R[E]

v ) 9F axi_bram_ctrl_0
[+ {} BRAM_PORTA
[ {} BRAM_PORTB
W5 ma
v [v) #F axi_gpio_0
[ 4 5_ax1
v [ T axi_vartlite_0
W) 0 5_Ax
v [+ F mdm_1
)0 TRIG_IN_0 Select an interface pin on the left panel to view its options

v I} TRIG_OUT_0
v [ T mig_Tseries_D
b 4 5 ma
v [ TF rst_mig_7series_0_100M

) = ext_reset_in

,

3. Use the following table to set options in the Run Connection Automation dialog
box.
Table 1: Run Connection Automation Options
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axi_bram_ctrl_0

« BRAM_PORTA

axi_bram_ctrl_0

- BRAM_PORTB

axi_bram_ctrl_ 0

.« S_AXI

The only option for this
automation is to
instantiate a new Block
Memory Generator as
shown under options.

The Run Connection
Automation dialog box
opens and gives you
two choices:

 Instantiate a new
BMG and connect
the PORTB of the
AXI block RAM
Controller to the
new BMG IP

o Use the previously
instantiated BMG
core and
automatically
configure it to be a
true dual- ported
memory and
connected to
PORTB of the AXI
block RAM
Controller.

Two options are
presented in this case.
The Master field can be
set for either cached or
non-cached accesses.
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axi_gpio_0

. S_AXI

axi_uartlite_0

. S_AXI

mdm_1

. TRIG_IN_O

mdm_1

. TRIG_OUT 0

mig_7series_0

. S_AXI

The Master field is set to
its default value of
/microblaze_0 (Periph).
The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

The Master field is set to
its default value of
/microblaze_0 (Periph).
The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

This will be connected to
a new System ILA core’s
TRIG_OUT pin.

This will be connected to
the System ILA
core’sTRIG_IN pin.

The Master field is set to
microblaze_0 (Cached).
Leave it to this value so
the accesses to the
DDR3 memory are
cached accesses.

Displayed in the footer
Page 18 of 75

changed to
/microblaze_0 (Periph).
Leave the Clock
Connection (for
unconnected clks) field
set to its default value of
Auto.

Keep these default
settings.

Keep these default
settings.

Leave the ILA
Connection settings to
its default value of Auto.

Leave the ILA
Connections settings to
its default value of Auto.

Keep these default
settings.



Programming an Embedded MicroBlaze Processor (XD131)

The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

Rst_mig_7_series_0_100M The reset pin of the Keep the default setting.
Processor Sys Rreset IP

will be connected to the

board reset pin.

o ext reset in

1. After setting the appropriate options, as shown in the table above, click OK.
At this point, your IP integrator diagram area should look like the following
figure.

Diagram
@ a X ®M o Q s + B * C g Default View v

# Designer Assistance available. Run Connection Automation

t

e s =11
a MicroBlaze ® e+

Note: The relative placement of your IP might be slightly different.
Mark Nets for Debugging

1. To monitor the AXI transactions taking place between the MicroBlaze and the
GPIO, select the interface net connecting MO0_AXI interface pin of the
microblaze 0 axi_periph instance and the S_AXI interface pin of the
axi_gpio_0 instance.

2. Right-click and select Debug from the context menu.

Note: The Designer Assistance is available as indicated by the Run
Connection Automation link in the banner of the block design.
3. Click Run Connection Automation.
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4. In the Run Connection Automation dialog box, go with the default setting as

shown in the following figure.

Run Connection Automation

Automatically make connections in your design by checking the baxes of the interfaces to connect. Select an interface on the left to display its configuration options on the right.

]+ & microblaze_0_axi_periph_MO0_AX] shows interface level events in the Hardware Manager in an intuitive way.

~ [ #F mdm_1
05 M Ontions

ANl Read Address: Data and Trigger +
AXI Read Data Data and Trigger +
AX| Write Address Data and Trigger +
AXI Write Data: Data and Trigger +
AXI Write Response Data and Trigger +
Source Clock: imig_7series_0/ui_addn_clk_0
System ILA: Auto v

AXI-MM Protocol Checker: [

- a

Q = % Description

v@ All Automation (1 out of 2 selected) Connect selected interface-connection andlor netto System ILA Gore for Debugging in Hardware Manager. System ILA
~ ¥ Interface Connections (Integrated Logic Analyzer) IP core is a logic analyzer which allows you to perform in-system debugging of designs and

ey

Cancel

5. Click OK.

6. Click the Regenerate Layout button C inthe IP integrator toolbar to generate
an optimum layout for the block design. The block diagram should look like the

following figure.

s s
—% MicroBlaze ®

Diagram oax
a i M o Q ¢+ B * C g Default View v &
P Designer Assistance available. Run Connection Automation

Note: The relative placement of your IP might be slightly different.

Add Connection Between MDM and AXI SmartConnect
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In order to enable JTAG-based debugging of the AXI BRAM Controller and the
DDR3 RAM, a connection between the MicroBlaze Debug Module (MDM) and AXI
SmartConnect must be made.

1. Click Run Connection Automation.
2. In the Run Connection Automation dialog box box set the Slave interface
option to either /axi_bram_ctrl_0/S_AXI or /Imig_7series_0/S_AXI.

Run Cennection Automation X

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its configuration options on
the right.

Q = = Description
- !
v W Al Automation (1 out of 1 selected) Connect Master interface mdm_1/M_AXI) to a selected Slave interface. To connect a Master interface to an
v mdm_1 unconnected Slave interface, please use connection automation starting from the Slave Interface.
) [ M_AXI
Options
Slave interface Jaxi_bram_ctrl_0iS_AXI ~
Bridge IP faxi_bram_ctrl_0/S_AXI
Imig_7series_0/S_AX]
Clock source for driving Bridge IP (100 MHz)
Jaxi_gpio_0iS_AXI
Clock source for Master interface | Jaxi_uartlite_0/S_AXI (100 MHz)
Clock source for Slave interface (100 MHz)

Either option will connect to the same AXI SmartConnect instance allowing for

JTAG memory access. 3. Click the Regenerate Layout button C inthe IP
integrator toolbar to generate an optimum layout for the block design. The block
diagram should look like the following figure.
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Diagram

Q a 3 X ¢ Q s |+ E * C o Default View v o

o + |l LN i
S — ey o

‘.,k,
Ty
M|
IS
53
7L
et

Note: The relative placement of your IP might be slightly different.

This connection connects the AXI4 master port of the MicroBlaze Debug Module
(MDM) to the AXI SmartConnect for direct access to memory from JTAG. This
allows fast program download, as well as transparent memory access when the
connected MicroBlaze processors are executing.

Step 3: Memory-Mapping the Peripherals in IP Integrator

1. Click the Address Editor window.
2. In the Address Editor, do the following:

-

a. Expand the microblaze_0 instance by clicking on the Expand All icon ~ in
the toolbar to the top of the Address Editor window.

b. Ensure the range of microblaze 0/mig_7_series_0/memmap IP in both the
Data and the Instruction section are 512 MB, and
mdm_1/mig_7_series_0/memmap also is 512 MB, as shown in the following
figure.
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Address Editor ? -0 aX
Q = s 1 ¥ Assigned (11) ¥ Unassigned (@) [+ Excluded (0) Hide All o
Mame 1 Interface  Slave Segment Master Base Address Range Master High Address

w2 Network 0

~ Imdm_1

hd Imdm_1/Data (32 address bits : 4G
3 Jaxi_bram_ctrl_0/S_axI S_AX Mem0 0xC000_0000 8K ~ O0xCO00_1FFF
1% /microblaze_0_local_memory/dimb_bram_if_cnti/SLMB- SLMB1 Mem 0x0 B4K ~ OxFFFF
1% /mig_7series_0/memmap S_AAl memaddr 0x3000_0000 512M ~ OxSFFF_FFFF

w Imicroblaze_0

W imicroblaze_0/Data (32 address bits - 4G
% faxi_bram_ctrl_0/S_AXI S_AXl Mem0 0xC000_0000 8K v 0xCO00_1FFF
1% faxi_gpio_0/S_AXl S_AXI Reg 0x4000_0000 B4K ~ 0x4000_FFFF
12 Jaxi_uartiite_0/S_AxI S_AXI Reg 0x4060_0000 BAK v  0x4060_FFFF
1% /microblaze_0_local_memory/dimb_bram_if_cnti’SLMB SLMB Mem 0x0 B4K ~ OxFFFF
¥ /mig_7series_0/memmap S_AX memaddr 0x3000_0000 512M ~ O0xSFFF_FFFF
w imicroblaze_0fnstruction (32 address bits 4G
% faxi_bram_ctrl_0/5_AXI S_AXI Iem0 0xC000_0000 8K v 0xCO00_1FFF
1% /microblaze_0_local_memoryfilmb_bram_if_cnti/SLMB SLMB Mem 0x0 B4K ~ OxFFFF
1% /mig_7series_0/imemmap S_AXl memaddr 0x3000_0000 512M ~ OxSFFF_FFFF

c. The top of the Address Editor window should show Assigned (11), indicating
all 11 interfaces were assigned addresses. If Unassigned shows any

interfaces unassigned, click on the Assign All arrow +

You must also ensure that the memory in which you are going to run and store your
software is within the cacheable address range. This occurs when you enable
Instruction Cache and Data Cache, while running the Block Automation for the
MicroBlaze processor.

To use either Memory IP DDR or AXI block RAM, those IP must be in the cacheable
area; otherwise, the MicroBlaze processor cannot read from or write to them.
Validating the design will automatically re-configure the MicroBlaze processor’s
cacheable address range.

Step 4: Validate Block Design

To run design rule checks on the design:

1. Click the Validate Design button on the toolbar, or select Tools > Validate
Design.
The Validate Design dialog box informs you that there are no critical warnings
or errors in the design.

2. Click OK.

3. Save your design by pressing Ctrl+S, or select File > Save Block Design.

Step 5: Generate Output Products

1. In the Sources window, select the block design, then right-click it and select
Generate Output Products. Alternatively, you can click Generate Block
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Design in the Flow Navigator.
The Generate Output Products dialog box opens.
2. Click Generate.

The following output products will be generated.
e\
Preview
Q = 2 |
W mb_subsystem.bd (O0C per IP) o
Synthesis
Simulation
Implementation
Hw Handoff b

Synthesis Options [
() Glopal
(®) Qut of context per IP
() Out of context per Block Design

Run Settings

iii On local host: Mumber of jobs: 8 w

() Generate scripts only

() Do notlaunch

I/"_:'\I B
\ 2 Generate Cancel

The Generate Output Products dialog box informs you that Out-of-context
module runs were launched.

3. Click OK.

4. Wait a few minutes for all the Out-of-Context module runs to finish as shown in
the Design Runs windows.
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Design Runs. ? Oax
Q = = + %
Name Constraints ~ Status WNS TNS WHS THS WBSS TPWS Total Power Falled Routes Methodology RQAScore QoRSuggestions LUT FF BRAM URAM  DSP
synth_1 (activ constrs 1 Not started
impl_1 constrs 1 Not started
Out-of-Context Module Runs
+ mb_subsystem Submodule Runs Complete
« mb_subsysten mb_subsyste synth_design Complete! 6462 5781 0 0 0
« mb_subsysten mb_subsyste synth_design Complete! 3421 300 22 0 3
« mb_subsysten mb_subsyste synth_design Complete! 48 64 [ 0 0
« mb_subsyster mb_subsyste synth_design Complete! 108 114 0 0 0
« mb_subsyster mb subsyste synth_design Complete! 283 266 0 0 0
« mb_subsyster mb_subsyste synth_design Complete! o 1 0 0 0
« mb_subsysten mb_subsyste synth_design Complete! o 1 0 0 0
« mb_subsysten mb_subsyste synth_design Complete! 83 74 [ 0 0
« mb_subsysten mb_subsyste synth_design Complete! 4 2 [ 0 0
« mb_subsyster mb subsyste synth_design Complete! 0 12 2 0 0
« mb_subsyster mb subsyste synth_design Complete!
« mb_subsysten mb_subsyste synth_design Complete! 43473 0 0 0
+ mb_subsysten mb_subsyste synth_design Complete! 19 40 [ 0 0
« mb_subsysten mb_subsyste synth_design Complete! 0 12 2 0 0
« mb_subsysten Submodule Runs Complete
+ mb_subsys mb subsyste synth_design Complete! 7335 894 0 0 0
« mb_subsysten mb_subsyste synth_design Complete! 134 130 0 0 0
« mb_subsysten mb_subsyste synth_design Complete! 10 0 0 0
+ mb_subsysten Using cached IP results
< >

Step 6: Create a Top-Level Wrapper

1. Under Design Sources, right-click the block design mb_subsystem and click
Create HDL Wrapper.
In the Create HDL Wrapper dialog box, Let Vivado manage wrapper and auto-
update is selected by default.

2. Click OK.

Create HDL Wrapper >

You can either add or copy the HDL wrapper file to the project. Use copy 1
aption if you would like to modify this file. [ 4

Options

1:: ::2 Copy generated wrapper to allow user edits

@ LetVivado manage wrapper and auto-update

I/;\I
\ ) OK Cancel

Step 7: Take the Design through Implementation

1. In the Flow Navigator, click Generate Bitstream.

The No implementation Results Available dialog box opens.
2. Click Yes.

The Launch Runs dialog box opens.
3. Make the appropriate choices and click OK.

Displayed in the footer
Page 25 of 75



Programming an Embedded MicroBlaze Processor (XD131)

Bitstream generation can take several minutes to complete. Once it finishes,
the Bitstream Generation Completed dialog box asks you to select what to do
next.

4. Keep the default selection of Open Implemented Design and click OK.

5. Verify that all timing constraints have been met by looking at the Timing -
Design Timing Summary window, as shown in the following figure.

Timing ?2-0aXx
Q = = 4 Design Timing Summary
»
General Information
Timer Seftings Setup
Design Timing Summary Worst Negative Slack (WNS):  0.994 ns Worst Hold Slack (WHS). 0.018ns Worst Pulse Width Slack (WPWS): 0.000 ns
Clock Summary (22 Total Negative Slack (TNS):  0.000 ns Total Hold Slack (THS) 0.000 ns Total Pulse Width Negative Slack (TPWS): 0.000 ns

Hold Pulse Width

Methodology Summary (27 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0
Check Timing (12
Intra-Clock Paths

’ Total Number of Endpoints: 64541 Total Number of Endpoints: 64523 Total Number of Endpoints: 25011
>

> 1= Inter-Clock Paths

>

>

>

All user specified timing constraints are met.
Other Path Groups

User Ignored Paths
Unconstrained Paths

Timing Summary -impl_1 (saved)

Note: The timing summary for your design might be slightly different.

Step 8: Export the Design to the Vitis software platform

ﬁ IMPORTANT! For the usb driver to install, you must power on and connect
the board to the host PC before launching the Vitis software platform.
Next, open the design and export to the Vitis software platform.

1. From the Vivado File menu, select File > Export > Export Hardware. The
Export Hardware Platform dialog box opens.

2. Click Next.

3. Select the Include bitstream option using the radio button in the Output view
and click Next.
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Export Hardware Platform X
Qutput
Setthe platform propedies to inform downstream tools of the intended use of the target platform’s hardware design.

() Pre-synthesis
* This platform includes a hardware specification for downstream software tools.

(®) Include bitstream
~ This platform includes the complete hardware implementation and bitstream, in addition to the hardware specification for
software tools.

4. Leave the XSA file name field at its default value and click Next. (The
following figure shows Windows-specific settings.)
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m Export Hardware Platform

Files

Enter the name of your hardware platform file, and the directory where the XSA file will be stored.

XSAfile name: mb_subsystem_wrapper

Export to:

The XS4 will be written to: mb_subsystem_wrapperxsa

| Finish |

| Cancel
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5. Click Finish. This will export the hardware XSA File in the project directory.

AM D n Exporting Hardware Platform
Vivado @ A newfixed hardware platform named 'mb_subsystem_wrapper will be written as
ML Edition mb_subsystem_wrapperxsa’.

© The platform will include a postimplementation model, including a bitstream description, describing
the hardware for downstream software tools.

To export the platform, click Finish.

/_\ .

6. To launch the Vitis software platform, select Tools > Launch Vitis IDE. The
Eclipse Launcher dialog box opens.

Step 9: Create a “Platform Component”
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The Vitis software platform launches in a separate window.

Welcome to the Vitis Unified IDE

Get Started

1. Select Open Workspace and select an new folder for the desired Workspace
location, such as C:\Projects\Vitis_Workspaces\microblaze-system (Windows-
specific).

2. Select File > New Component > Platform or under Embedded
Development click Create Platform Component.

Go

Welcome to the Vitis Unified IDE

Get Started
aaaaa

&u
u
u
[

iwIP TCP Perf Client

B ©oAo

3. Click Next.
4. In the Platform Creation Flow window, select the Hardware Design option and
Click Browse to open the Select Hardware Design (XSA) window. Navigate to
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the directory where the XSA file was created in Vivado and click Open.

Create Platform Component
Name and Location » Flow > OSand Processor >
Select Platform Creation Flow
Create a platform component by selecting the hardware design and add software domains.

C) Existing Platform

@ Hardware Design

Hardware Design (X5A) T Pesoraliass s\ mb_subsystem_wrapp... v Browse

| Cancel )

5. Click Next.
6. In the Operating System and Processor window, select the standalone for the
operating sytem and microblaze_0 for the processor.

Create Platform Component

Name and Location > Flow > OSand Processor > Summary
Select Operating System and Processor

Specify the details for the initial domain to be added to the platform component. More domains can be added and user can edit the domain settings later by opening

the platform editor.

Operating system: | standalone

Processor: | microblaze 0

| Cancel )

7. Click Next.
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8. Review the Platform Component Creation Summary and click Finish.

Create Platform Component

Name and Location » Flow > OSand Processor > Summary

Summary

The following new Platform component will be created

Name platform

Workspace B og@Ts WS IWONY Spa @5 T OEATE Sy Stee
Component directory Pr gty Witn Work spdc 83 e oEIe Sy ster plattonm
Operating system standalone

Processor microblaze_0

Step 10: Create a “Peripheral Test” Application

1. Select File > New Component > From Examples or under Get Started click
Examples.

minal Help Vitis

1 weicome *

Welcome to the Vitis Unified IDE

Get Started HLS Development Embedded Development
& Open Workspace

& Bxamples

2 Migrate classic IDE workspace
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2. Select Peripheral Tests.

C1 File Edit Selecton View Go Terminal Help Vitis

DN Wekcome *| @ peripherai Tests X

Peripheral Tests

Simple test r

)
P Echo Se
Hierarchical name ~ pe:
IwIP TCP Per
IwIP TCP Per i
IwIP UDP Perf Client

IWIP UDP Perf Server

[ R e e R

®

IwIP UDP Perf Client

OpenAMP echo-test

OpenAMP matrix multiplication Demo.

rooOO oD

OpenAMP RPC Demo

>oo o

»

Coeoo o

®0A0

3. Click on Create Application Component from Template.

Create Application Compenent - Peripheral Tests

Name and Location > Hardware >

Name and Location

Choose a name for your component and specify a directory where component data files will be stored

Component location - WOk npe @3 e NEIe e Browse

Component will be created at EAFaiseiien Watapeosssiorabises sy peripheral_tests

4. Click Next.
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5. In the Platform page, select the previously created platform.

Create Application Component - Peripheral Tests

Name and Location > Hardware > Domain >

Select Platform

Platforms supporting the selected example from your repositories. To create a new platform, use "File - New Component -* Platform™

fo

VENDOR PATH

— pesttreti e - -tor ~.Workspaces\microblaze-system\platform\export\platform

© platform Embedded ailimecom  ..roblaze-system\platform\export\platform\platform.xpfm

| Cancel )

6. Click Next.
7. In the Domain page leave all the fields at their default values and click Next.

Create Application Component - Peripheral Tests

Name and Location > Hardware > Domain > Summary

Select Domain

Choose a domain from the available domains in the platform

Name Details

standalone_microblaze_0
Name standalone_microblaze_0

+ create new...

Display Name standalone_microblaze_0

0s standalone

Processor micoblaze 0

| Cancel )
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8. Review the Summary and click Finish.

Create Application Compenent - Peripheral Tests

Name and Location > Hardware > Domain > Summary

Summary

The following new application component will be created

Name peripheral_tests

Workspace P s Wi Wk wpae 84 e 7 ol Sy Sten

Component directory Progciy'vs_ Workspeoes e olslase syster' peripheral_tests
Platform platform

Domain standalone_microblaze_0 (OS:standalone, Processormicroblaze_0)

) ( Finish )

9. Anew peripheral_tests application is created. If the testperiph.c file is
not already open, select MICROBLAZE-SYSTEM/peripheral_tests
[Application]/Sources/src/testperiph.c, and double-click to open the source
file. Modify the source file by inserting a while statement at approximately line
18. Press Ctrl + S to save the file.

a. In line 18, add while(1) above the curly brace as shown in the following
figure.

10. To build the application select peripheral_tests under Flow > Component
and click on Build. Click OK on the pop-up window to build the associated
platform.
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~ FLOW ¥ A

Component ® peripheral_tests v | gs&

e

&7 Build <

11. Wait for the application to finish compiling.

Step 11: Execute the Software Application on a SP701 Board

ﬁIMPORTANT! Make sure that you have connected the target board to the
host computer and it is turned on.

1. To start the debug session, click on the Debug icon under Flow > Component

[peripheral_tests] > Debug.

A

~ FLOW ¥

Component B peripheral_tests A &‘}

77 Build &

[> Run
3 Debug

2. The Debug perspective window opens, if the testperiph.c file is not already
ct ..Isrcltestperiph.c, and double-click to open the source file.

View Go Terminal Help

open, sele

T0_6_BASEADDR) ;

v BREAKPOINTS

1n12,Col2 CRIF UTF8 Spacesid C O B3

B® ©1A1 dangdide X1
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3. Add a breakpoint in the code so that the processor stops code execution when
the breakpoint is encountered. To do so, scroll down to line 24 and click on the
left pane red dot, which adds a breakpoint on that line of code, as shown in

the following figure.

4. Configure your terminal program (e.g., TeraTerm, Putty) to connect to the
SP701 Serial Port with the settings shown below.

(o]
o
o
o

(0]

Step 12:

Baud rate = 9600
Data bits = 8

Stop bits =1

Flow control = None
Parity = None

Connect to Vivado Logic Analyzer

Connect to the SP701 board using the Vivado Logic Analyzer.

1. In the Vivado IDE session, from the Program and Debug drop-down list of the
Vivado Flow Navigator, select Open Hardware Manager.
2. In the Hardware Manager window, click Open target > Open New Target.

HARDWARE MAMAGER - unconnected

@ No hardware target is open. Open target

Hardware

The Open New Hardware Target dialog box opens, shown in the following
figure.
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Open Mew Hardware Target X
AM D u Open Hardware Target
. This wizard will guide you through connecting to a hardware target.
Vivado
ML Edition To connectto a remote hardware target, provide the host name and IP port of the remote machine on which the

instance of a Vivado Hardware Server is running.

Cancel

8]
5
=

3. Click Next.

4. On the Hardware Server Settings page, ensure that the Connect to field is set
to Local server (target is on local machine) as shown in the following figure,
and click Next.

Open New Hardware Target *
Hardware Server Settings
Select local or remote hardware server, then configure the host name and port settings. Use Local server if the targetis attached to the

local machine; otherwise, use Remote server.

Connectto: | Local server (target is on local machine) -

Click Next to launch andl/or connectto the hw_server (port 3121) application on the local machine.

oy
(3]
\9/

5. On the Select Hardware Target page, click Next.
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6. Ensure that all the settings are correct on the Open Hardware Target
Summary dialog box and click Finish.

Note: You can also use the Auto Connect option to connect to the target hardware.

Step 13: Set the MicroBlaze to Logic Cross Trigger

When the Vivado Hardware Session successfully connects to the SP701 board, you
see the information shown in the following figure:

Hardware

Q| = | @ > » N o

Marme Status

I localhost Connected
B o xilinx_tcf/Xilinx/1281038a087A Open
& xc7s100.0(2) Programmed

XADC
b _ila_1 Idle

1. Select the Settings - hw_ila_1 tab and set the Trigger Mode Settings as
follows:
1. Set Trigger mode to TRIG_IN_ONLY.
2. Set TRIG_OUT mode to TRIG_IN_ONLY.
3. Under Capture Mode Settings, ensure that Trigger position in window is
set to 512.

hwila 1

Waveform - hw _ila_1

gla + e > » BB @ a X ¥ o 1M T o
2 o

Settings - b 2 1 % Status - hw ila 1 Trigger Setup - hw ila_1 Capture Setup - hw ila_1
Trigger Mode Settings + o,
Trigger mode:  TRIG_IN_ONLY v

TRIG_OUT mode: | TRIG_IN_ONLY v

Capture Mode Settings
Capture mode:
Number of windows
Window data depth: 1024
ion in window: | 512
General Settings

Refresh rate: | 500
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2. Arm the ILA core by clicking the Run Trigger * button.
This arms the ILA. You should see the status “Waiting for Trigger” in the
Status - hw_ila_1 tab as shown in the following figure.

Settings - hw_ila_1 Status - hw ila_1
r » » N
Core status L Waiting for Trigger

Capture status - Window 1 of 1

Window sample 512 of 1024

I

3. In the Vitis software platform Debug window, click MicroBlaze #0 and then
click the Continue button ﬂ

The code will execute until the breakpoint set on line 24 in testperiph.c file is
reached. As the breakpoint is reached, this triggers the ILA, as shown in the

following figure.

[ waveform - hwila 1

I
2la + > > » B @A a M ¥ o Ko o[- - &

ILA Status: Waitina For Triaaer (512 out of 1024 samples)

This demonstrates that when the breakpoint is encountered during code execution,
the MicroBlaze triggers the ILA that is set up to trigger. This way you can monitor
the state of the hardware at a certain point of code execution.

Step 14: Set the Logic to Processor Cross- Trigger

Now try the logic to processor side of the cross-trigger mechanism. In other words,
remove the breakpoint that you set earlier on line 24 to have the ILA trigger the

Displayed in the footer
Page 40 of 75



Programming an Embedded MicroBlaze Processor (XD131)

processor and stop code execution.

1. Select the Breakpoints tab towards the bottom left corner of the window, and
clear the testperiph.c [line: 24] check box. This removes the breakpoint that
you set up earlier.

Alternatively, you can also right click on the breakpoint in the testperiph.c
file, and select Disable Breakpoint.

2. In the Debug window, right-click the MicroBlaze #0 target and select
Continue button &,

The code runs continuously because it has an infinite loop.
You can see the code executing in the Terminal Window.

3. In Vivado, select the Settings - hw_ila_1 tab. Change the Trigger Mode to
BASIC_OR_TRIG_IN and the TRIG_OUT mode to TRIGGER_OR_TRIG_IN.

4. Click on the (+) sign in the Trigger Setup window to add the slot 0 :
microblaze @ axi_periph_Mee_ _AXI : AWVALID signal from the Add
Probes window.

5. In the Trigger Setup window, for slot_0 :
microblaze 0@ axi_periph_Me@_AXI : AWVALID signal, ensure that the
Operator field is set to ==, the Radix field to [B] (Binary) and the Value field to
1 (logical one).

This essentially sets up the ILA to trigger when the awvalid transitions to a
value of 1.

Trigger Setup - hw_ila_1 Capture Setup - hw_ila_1
o + = o

Name Operator Radix Walue Port Comparator Usage

slot_0: microblaze_0_axi_periph_MOD_AXI: AWVALID == v @ v probed3o] 1 of 1

6. Click the Run Trigger button to ‘arm’ the ILA in the Status - hw_ila_1 window.
The ILA immediately triggers as the application software is continuously
performing a write to the GPIO thereby toggling the
net_slot O\ axi_awvalid signal, which causes the ILA to trigger. The ILAin
turn, toggles the TRIG_OUT signal, which signals the processor to stop code
execution.

This is seen in Vitis in the highlighted area of the debug window.
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~ DEBUG
~ xc/s100
* MicroBlaze Debug Module at USER2
MicroBlaze #0 PAUSED ON EXTERNAL DEBUG REQUEST

Legacy Debug Hub

~ CALL STACK

0x800016a4 XGpio_DiscreteClear(): xgpio_... xgpio_extra.c
0x80000520 GpioOutputExample... :-:gpiﬂ_tapp_example.c
0x80000380 main(): testperiph.c. line 22 testperiph.c
0x80000300 _crtinit(): crtinit.s, line 126 criinit.5

0x80000024 _start1(: crt0.s, line 122 crto.s

Conclusion
In this tutorial, you:

» Stitched together a design in the Vivado IP integrator

» Took the design through implementation and bitstream generation

» Exported the hardware to Vitis

« Created and modified application code that runs on a Standalone Operating
System

» Modified the linker script so that the code executes from the DDR3 memory

» Verified cross-trigger functionality between the MicroBlaze processor
executing code and the design logic

Lab Files

The Tcl script 1ab_classic_mb.tcl is included with the design files to perform all
the tasks in Vivado. The Vitis software platform operations must be done in the Vitis
GUI. You will need to modify the Tcl script to match the desired project path and
project name on your machine.

Copyright © 2019-2024 Advanced Micro Devices, Inc.
Terms and Conditions
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Programming an Embedded MicroBlaze V
Processor

In this tutorial, you will create a simple AMD soft-processor system for a Spartan-7
FPGA using AMD Vivado™ [P integrator.
This tutorial uses the new AMD MicroBlaze™ V soft-core RISC-V processor.

Introduction

The MicroBlaze V system includes native AMD IP including:

» MicroBlaze V processor

o AXI block RAM

e Double Data Rate 3 (DDR3) memory
« UARTLIite

« AXI GPIO

e MicroBlaze Debug Module (MDM) V
e Proc Sys Reset

e Local memory bus (LMB)

Parts of the block design are constructed using the Platform Board Flow feature.
This lab also shows the cross-trigger capability of the MicroBlaze V processor.
The feature is demonstrated using a software application code developed in the
Vitis software platform in a stand-alone application mode.

This lab targets the AMD SP701 FPGA Evaluation Kit.

Step 1: Start the Vivado IDE and Create a Project

1. Start the Vivado IDE by clicking the Vivado desktop icon or by typing vivado
at a command prompt.

2. From the Quick Start page, select Create Project.

3. In the New Project dialog box, use the following settings:
a. In the Project Name dialog box, type the project name and location.
b. Make sure that the Create project subdirectory check box is selected.
Click Next.
c. In the Project Type dialog box, select RTL project. Ensure that the Do not
specify sources at this time check box is cleared. Click Next.
d. In the Add Sources dialog box, set the Target language to either VHDL or
Verilog. You can leave the Simulator language selection to Mixed.

Displayed in the footer
Page 43 of 75



Programming an Embedded MicroBlaze Processor (XD131)

e. Click Next.

f. In Add Constraints dialog box, click Next.

g. In the Default Part dialog box, select Boards and choose Spartan-7 SP701
Evaluation Platform. Click Next.

h. Review the project summary in the New Project Summary dialog box and
click Finish to create the project.

Because you selected the SP701 board when you created the Vivado IDE project,
you see the following message in the Tcl Console:

set_property board_part xilinx.com:sp701:part0:1.1
[current_project]

Although Tcl commands are available for many of the actions performed in the
Vivado IDE, they are not explained in this tutorial. Instead, a Tcl script is provided
that can be used to recreate this entire project. See the Tcl Console for more
information. You can also refer to the Vivado Design Suite Tcl Command Reference
Guide (UG835) for information about the write bd tcl commands.

Step 2: Create an IP Integrator Design

1. From Flow Navigator, under IP integrator, select Create Block Design.

2. Specify the IP subsystem design name. For this step, you can use
mbv_subsystem as the Design name. Leave the Directory field set to its
default value of <Local to Project>. Leave the Specify source set drop-down
list set to its default value of Design Sources.

3. Click OK in the Create Block Design dialog box, shown in the following figure.

E Create Block Design -

Please specify name of block design.
e\
Design name: mbv_subsystem
Directory: » <=Localto Project= e
Specify source set: Design Sources v

4. In the IP integrator diagram area, right-click and select Add IP.
The IP integrator Catalog opens. Alternatively, you can also select the Add IP
icon in the middle of the canvas.

+
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5. Type mig in the Search field to find the MIG core, then select Memory
Interface Generator (MIG 7 Series), and press Enter.

Search: mid (1 match)

Memory Interface Generator (MIG 7 Series)

EMTER to select, ESC to cancel, Ctrl+Q for IP details

The Designer Assistance link becomes active in the block design banner.
6. Click Run Block Automation.

Diagram 200 X
(€] HE O Q + E » C g Default View v o

* Designer Assistance available. Run Block Autornation Run Connection Automation

mig_7series_0

||+ ek rer
sys_rst

Memory Interface Generator (MIG 7 Series)

The Run Block Automation dialog box opens.
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Run Block Automation *

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its configuration options on the right.

o - -
= -

~ [+ All Automation (1 out of 1 selected)

Description

o Connect Board Part Interface to MIG IP.
[+ - mig_7series_D
Instance: /mig_7series_0

Options

Board_Part_Interface:  ddr3_sdram

(2)

7. Click OK. This instantiates the MIG core and connects the I/O interfaces to the
I/O interfaces for the DDR memory on the SP701 board.

mig_7series_0

DDR3 + ||l=—="> ddr3_sdram

4+ S_AXI ui_clk_sync_rst =
sys_diff_ clock [m|| + sys_cik ui_clk =
4 sys_rst ui_addn_clk 0 =
4 aresetn mmeom_locked =

init_calib_complete =—

Memory Interface Generator (MIG 7 Series)

8. Right-click anywhere in the block design canvas, and select Add IP. The IP
catalog opens.

9. In the Search field, type micr to find the MicroBlaze V |IP, then select
MicroBlaze V, and press Enter.

Note: If not displayed by default, the IP Details window can be displayed by clicking
CTRL+Q on the keyboard while searching for IP.
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Search: micr (6 matches)

MicroBlaze

MicroBlaze Debug Madule (MOM)
MicroBlaze Debug Maodule (MDM) W
MicroBlaze MC3

MicroBlaze MCS WV

MicroBlaze vV

EMNTER to select, ESC to cancel, Ctrl+C for IP details
IP Details b4

Mame: MicroBlaze V
Yersion: (Rev. )
Interfaces:  AXl4, AxXl4-Stream

Description: The Xilinx MicroBlaze V soft processor core, implementing the
free and open RISC-V Instruction Set Architecture.

Status: Froduction

License: Included

Change Log: View Change Log

Yendaor: Xilinx, Inc.

WL ¥ilime.com:ip:microblaze_riscv1.0
Repository:  CuXilindVivado/2024.1/datalip

Use the Board Window to Connect to Board Interfaces

There are several ways to use an existing interface in IP integrator. Use the Board
window to instantiate some of the interfaces that are present on the SP701 board.

1. Navigate to the Windows>Board.
2. Select the Board window to see the interfaces present on the SP701 board.
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Board ?T 08X
Q = & w
I8 Spartan-7 SPT01 Evaluation Platform
~ = Clock Sources (0 out of 1 connected
O System differential clock
Ethernet Configurations (0 out of 2 connected
2 Onboard PHY 1
*2 Onboard PHY 2
External Memory (1 out of 2 connected
*8 DDR3 SDRAM
¥ 5P flash
General Purpose Input or Output (0 out of 3 conne
2 DIP switches
¥JLED

¥ Push buttons

v [= Miscellaneous (0 out of 2 connected
¥ I
¥ UART

~ = Pmod (0 out of 6 connected)

*2 Connector PMODN
2 Connector PMOD2
2 Connector PMOD3
*2 Connector PMOD4
2 Connector PMODS
¥ Connector PMODE
Reset (0 out of 1 connected
O FPGA Reset
£ >

In the Board window, notice that the DDR3 SDRAM interface is connected as
shown by the circle ™ in the following figure. This is because you used the
Block Automation feature in the previous steps to connect the MIG core to the
board interfaces for DDR3 SDRAM memory.
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Board ? O a1 X
Q = & w
I8 Spartan-7 SPT01 Evaluation Platform
Clock Sources
» System differential clock

Ethernet Configurations

2 Onboard PHY 1

¥ Onboard PHY 2
External Memory (1

* DDR3 SDRAM

%3 SP| flash
General Purpose Input or Qutput

%2 DIP switches

KJLED

2 Push buttons e

3. From the Board window, select UART under the Miscellaneous folder, and
drag and drop it into the block design canvas.
This instantiates the AXI Uartlite IP on the block design.

4. From the Board window, select LED under the General Purpose Input or
Output folder, and drag and drop it into the block design canvas.
This instantiates the GPIO IP on the block design and connects it to the on-
board LEDs.

5. Next, from the Board window, select FPGA Reset under the Reset folder, and
drag and drop it into the block design canvas.
This connects the CPU push button reset to the MIG core IP.
The block design now should look like the following figure.

Diagram |x | Address Editor x AddressMap x 200
e N m © Q + & A C 9 Default View - o

¥ Designer Assistance available. Run Block Automation

microblaze_riscv_0

I wTerRUeT

e Bl RISC

Reset
ddr3_sdram
lad_Bbits:

sys_diff_clack
resat
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Add Peripheral: AXI block RAM Controller

1. Add the AXI block RAM Controller, shown in the following figure, by right-
clicking the IP integrator canvas and selecting Add IP.

Search: axi bram (1 match)

AX| BRAM Controller

ENTER to select, ESC to cancel, Ctrl+Q for IP details

IP Details X

Mame: AX| BRAM Controller
Version: (Rev. )
Interfaces: AXl4

Description: The AXl Block RAM (BRAM) Controller is a soft IP core. The
core is designed as an AX| Endpoint slave [P for
integration with the AXl interconnect and system master
devices to communicate to local block RAM. The caore
supports both single and burst transactions to the block

RAM and is optimized for peformance.
W

The block design now should look like the following figure.
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Diagram ? Ooa x

Q@ 3 M ¢ Q =+ E cC o Default View v o

# Designer Assistance available. Run Block Automation Run Connection Automation

o beam gt 0

o4 s

i wm SoRIA +
A R PR
. i_wwsen

o 4
e

s ¥ _dock [

Run Block Automation

1. Click Run Block Automation, as shown below.

Address Editor * | Address Map «  Diagram
@ @ = 2 Q + E » C 9 Default View v

* Designer Assistance available. Run Block Automation Run Connection Automation

The Run Block Automation dialog box opens.
2. On the Run Block Automation dialog box:
a. Leave Preset as the default value, None.
b. Set Local Memory to 64 KB.
c. Leave the Local Memory ECC as the default value, None.
d. Set Cache Configuration to 32 KB.
e. Set Debug Module to Debug Enabled.
f. Leave the Peripheral AXI Port option as the default value, Enabled.
g. Leave the Interrupt Controller option unchecked.
h. Leave The Clock source option set to /mig_7series_0/ui_addn_clk_0 (100
MHz).
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| Run Block Automation *
| Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the Ieft to display its configuration options on the right.
|

Qa x s

~ [+ All Aautomation (1 out of 1 selected)

Description

S MicroBlaze V connection automation generates local memory of selected size, and caches can be configured. Debug
s/ % microblaze_riscv_0 Module, Peripheral AX] Interconnect, Interrupt Controller, a clock source, Processor System Reset are added and
connected as needed. A preset MicroBlaze V configuration can also be selected.

Information about the options can be found in the tooltips

Options
Preset None ~
Local Memaory 64KB w
Local Memory ECC Mone w
Cache Configuration 32KB “
Bemug o
Peripheral AXI Port Enabled  w

(") Interrupt Controller

Clock Connection imig_7series_Oi_addn_clk_0 (100 MHz)  ~

(2)
\z) OK Cancel

3. Click OK.
This generates a basic MicroBlaze V system in the IP integrator diagram area,
as shown in the following figure.

Diagram  x Address Editor x| Address Map  x ?00

Q M O Q s + = » C o Default View ~ o

J Designer Assistance available. Run Connection Automation

microblaze_riscv_0 axi_gpio_0

mdm_1 DLME [y - 5

[+ wrersuer
LB || 8 2% ack GO+ ||jee > Jad_0its

N ——— RrRISC w_AXLDP + ! s ot_aresatn ! -
Detug_SYS_Rst ox A W0 ] -
Resd LALDE + i

MicroBlaza Dabug Modula (MDM) e [t AAERIO

mig_Tsenas_0

MicoBlaze V

oors + ||
[+ s a1 ek _syne_est

+ svs cu e
sysre i_adan_ok 0
aresen fnemam_ocked
in_gann_camplete

{ ddr3_sdram

fricroblaze_tiscv_0_local memary

rsl_mig_Tsaries_0_100M

sys_diff_clock D—|I

reset

—1

ext_resat in bus_stuet reseqa:)
sux_rasat in pariphersl_msst0 0]
Mo deug sys rsl inlemonnect areseni]
aem_lossea penipheral_reseno:0]

axi_bram_c¥l_0

Memory Intarfaca Generalor (M

e am

srav_poRTA ||

Processar System Resat BRAM_PORTE —+ ||

AXIBRAM Canlralk

AXI Uartite

Use Connection Automation

Run Connection Automation provides several options that you can select to make
connections. This section will walk you through the first connection, and then you
will use the same procedure to make the rest of the required connections for this

tutorial.
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1. Click Run Connection Automation as shown in the following figure.

Diagram
@ QO un & O Q s +
* Designer Assistance available. Run Connection Automation

The Run Connection Automation dialog box opens.

2. Check the All Automation check box in the left pane of the dialog box as
shown in the following figure. This selects interfaces to run Connection
Automation for.

Run Connection Automation X

| Autematically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its configuration options on |
the right

-

-

4L

v

w

=]

| Automation (7 out of 7 selected]|
T axi_bram_ctrl_D
[v] {} BRAM_PORTA
[+ {} BRAM_PORTB
)0 5_AKI
v [+ ¥ axi_gpio_0
) O 5_Ax
v [ T axi_uartlite_0
) 0 s_AxI
v [ TF mig_Tseries_0
W0 s_Ax Select an interface pin on the left panel to view its options

v

®

v [ ¥ rst_mig_7series_0_100M
) = ext_reset_in

| ®
3. Use the following table to set options in the Run Connection Automation dialog

box.
Table 1: Run Connection Automation Options

axi_bram_ctrl_0 The only option for this Leave the

automation is to Blk_Mem_Gen to its
instantiate a new Block default option of Auto.
Memory Generator as

shown under options.

« BRAM_PORTA
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axi_bram_ctrl_0

- BRAM_PORTB

axi_bram_ctrl_0

. S_AXI

The Run Connection
Automation dialog box
opens and gives you
two choices:

« Instantiate a new
BMG and connect
the PORTB of the
AXI block RAM
Controller to the
new BMG IP

» Use the previously
instantiated BMG
core and
automatically
configure it to be a
true dual- ported
memory and
connected to
PORTB of the AXI
block RAM
Controller.

Two options are
presented in this case.
The Master field can be
set for either cached or
non-cached accesses.
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axi_gpio_0

. S_AXI

axi_uartlite_0

. S_AXI

mig_7series_0

« S_AXI

The Master field is set to
its default value of
/microblaze_0 (Periph).
The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

The Master field is set to
its default value of
/microblaze_0 (Periph).
The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

The Master field is set to
microblaze_0 (Cached).
Leave it to this value so
the accesses to the
DDR3 memory are
cached accesses.

The Clock Connection
(for unconnected clks)
field is set to its default
value of Auto.

Rst_mig_7_series_0_100M The reset pin of the

o ext _reset in

Processor Sys Rreset IP
will be connected to the
board reset pin.

unconnected clks) field
set to its default value of
Auto.

Keep these default
settings.

Keep these default
settings.

Keep these default
settings.

Keep the default setting.

1. After setting the appropriate options, as shown in the table above, click OK.
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At this point, your IP integrator diagram area should look like the following
figure.

a X X o Q s + & # C o Default View v &

Note: The relative placement of your IP might be slightly different.

Mark Nets for Debugging

1. To monitor the AXI transactions taking place between the MicroBlaze and the
GPIO, select the interface net connecting MOO_AXI interface pin of the
microblaze_riscv_0_axi_periph instance and the S_AXIl interface pin of the
axi_gpio_0 instance.

2. Right-click and select Debug from the context menu.

Note: The Designer Assistance is available as indicated by the Run
Connection Automation link in the banner of the block design.

3. Click Run Connection Automation.

4. In the Run Connection Automation dialog box, go with the default setting as
shown in the following figure.
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Run Connection Automation X
|
| Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its configuration options on the right
Q = = Description

v v
&) All Automation (1 aut of 1 selected) Connect selected interface-connection andior netto System ILA Core for Debugging in Hardware Manager. System ILA

[ Interface Connections (Integrated Logic Analyzer) IP core is a logic analyzer which allows you to perform in-system debugging of designs and
[+] =+ & microblaze_riscv_0_axi_periph_WM00_AXI shows interface level events in the Hardware Manager in an intuitive way.

| Options
AXlI Read Address Data and Trigger ~
A¥l Read Data: Data and Trigger ~
AX] Write Address: Data and Trigger +
AX| 'Write Data: Data and Trigger ~

| AXI'Write Response Data and Trigger ~

| Source Clock mig_Tseries_0/ui_addn_clk_0
System ILA: Auto v

AXI-MM Protocol Checker: [

Py
@

. Click OK.

. Click the Regenerate Layout button C inthe IP integrator toolbar to generate

an optimum layout for the block design. The block diagram should look like the
following figure.

Address Editor x| AddressMap x| Diagram  x 200

e H o om O Q : + = * C 9 Default View ~ -3

£ led_Suis

£ re212_sant

Note: The relative placement of your IP might be slightly different.

Step 3: Memory-Mapping the Peripherals in IP Integrator

1. Click the Address Editor window.
2. In the Address Editor, do the following:

a. Expand the microblaze_0 instance by clicking on the Expand All icon % in
the toolbar to the top of the Address Editor window.

Displayed in the footer
Page 57 of 75



Programming an Embedded MicroBlaze Processor (XD131)

b. Ensure the range of microblaze_riscv_0/mig_7 series_0/memmap IP in
both the Data and the Instruction section are 512 MB, as shown in the
following figure.

Address Editor Address Map Jiagram

Q = = 1 [#] Assigned (2) +| Unassigned (0) ) Excluded (0) Hide Al
Name 1 nterface Slave Segment Master Base Address Range Master High Address
~ B Network 0

hd Imicroblaze_riscv_0

A Imicroblaze_riscv_0/Data (32 address bits 1 4G
% faxi_bram_ctrl_0/S_AXI S_AX Mem0 0xC000_0000 8K -  0xCO00_1FFF
8 faxi_gpio_0rS_AXI S_AXI Reg 0x4000_0000 B4K +  0x4000_FFFF
¢ faxdi_uartlite_0/5_AXI S_Ax Reg 0x4060_0000 B4K -  0x4060_FFFF
¥ /microblaze_riscv_0_local_memory/dimb_bram_if_cntlr SLMB IMem 0x0 G4K ~ OxFFFF
¢ Imig_Tseries_0/imemmap S_AK memaddr 0x8000_0000 512M * (xSFFF_FFFF
~ Imicroblaze_riscv_0/nstruction (32 address bits : 4G
L Jaxi_bram_ctrl_0/5_Axl S_Ax Memo 0xCO00_0000 8K * 0xCO000_lFFF
1% imicroblaze_riscv_0_local_memoryfilmb_bram_if_cntlr/S SLMB Mem 0xd GdK » OxFFFF
1% /mig_Tseries_0/memmap S_AX memaddr 0x3000_0000 512M - OxSFFF _FFFF

c. The top of the Address Editor window should show Assigned (11), indicating
all 11 interfaces were assigned addresses. If Unassigned shows any

interfaces unassigned, click on the Assign All arrow +

You must also ensure that the memory in which you are going to run and store your
software is within the cacheable address range. This occurs when you enable
Instruction Cache and Data Cache, while running the Block Automation for the
MicroBlaze V processor.

To use either Memory IP DDR or AXI block RAM, those IP must be in the cacheable
area; otherwise, the MicroBlaze V processor cannot read from or write to them.
Validating the design will automatically re-configure the MicroBlaze V processor’s
cacheable address range.

Step 4: Validate Block Design
To run design rule checks on the design:

1. Click the Validate Design button on the toolbar, or select Tools > Validate
Design.
The Validate Design dialog box informs you that there are no critical warnings
or errors in the design.

2. Click OK.

3. Save your design by pressing Ctrl+S, or select File > Save Block Design.

Step 5: Generate Output Products

1. In the Sources window, select the block design, then right-click it and select
Generate Output Products. Alternatively, you can click Generate Block
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Design in the Flow Navigator.
The Generate Output Products dialog box opens.
2. Click Generate.

Generate Output Products
The following output products will be generated.
Preview
Q = =
W mbv_subsystem.bd (OOC per IF) N
Synthesis |
Simulation

Implementation
Hw Handoff M
| Synthesis Options
() Glopal
(®) Qut of context per |P
() Qut of context per Block Design

Run Settings
iii On local host: Mumber of jobs: 8 w

() Generate scripts only

() Do not launch

|/":'\| =
\ 2 Generate Cancel

The Generate Output Products dialog box informs you that Out-of-context
module runs were launched.

3. Click OK.

4. Wait a few minutes for all the Out-of-Context module runs to finish as shown in
the Design Runs windows.
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Design Run: 2_oax

Q = £ > + %

Name onstraints  Status Progress WNS TNS WHS THS WBSS TPWS TotalPower FailedRoutes Methodology ROAScors CoRSuggestons LUT FF BRAM URAM DSP

~ [ synth_1 (active constrs_1  Not started o
im constrs1 ot started 0%

~ Out-of-Context Module Runs

Submodule Runs Complete ™ 100%
+/ Miv_subsyster mOv_subsyst synith_design Camplete! -100% 507 a4 0 o 0
/ miy_subsyster mibv_subsyst synth_design Complete! - 100% 2338 180° 20 0 o
+/ Miv_subsyster mOv_subsyst synith_design Camplete! - 100% 108 114 0 o 0
¥/ miy_subsyster mibv_subsyst synth_design Complete! - 100% RN 0 oo
+/ Miv_subsyster mOv_subsyst synith_design Camplete! - 100% 263 288 0 o 0
< miby_subsyster mby_subsyst synth_design Complete! - 100% o 1 0 oo
 miv_subsyster mov_subsyst Using cachied IP results - 100%
< miby_subsyster mby_subsyst synth_design Complete! - 100% 4 2 0 oo
+/ Miby_subsyster mbv_subsyst synih_design Complete! -100% 4 2 0 o 0
< miby_subsyster mby_subsyst synth_design Complete! - 100% 0 12 1 oo
¥/ mby_subsyster mbv_subsyst synih_design Complete! = 100% 134 18 0 o 0
< miby_subsyster mby_subsyst synth_design Complete! - 100% 19 40 0 oo
¥/ mby_subsyster mbv_subsyst synih_design Complete! = 100% 0 12 2 o 0

v/ mby_subsyster Submodule Runs Complete - 100%
~/ MOy_SubsyE mby_subsyst synth_design Complete! = 100% 4895 6200 0 o 0
+/ mby_subsyster mby_subsyst synth_design Complete! - 100% 134 130 0 0 0
v+ mov_subsyster Submodule Runs Complete 1 100%
+/ mby_subsye mby_subsyst synth_design Complete! - 100% 1607 2320 35 0 0
< >

Step 6: Create a Top-Level Wrapper

1. Under Design Sources, right-click the block design mbv_subsystem and click
Create HDL Wrapper.
In the Create HDL Wrapper dialog box, Let Vivado manage wrapper and auto-
update is selected by default.

2. Click OK.

Create HDL Wrapper >

You can either add or copy the HDL wrapper file to the project. Use copy 1
aption if you would like to modify this file. [ 4

Options

() Copy generated wrapper to allow user edits

(®) Letvivado manage wrapper and auto-update

Step 7: Take the Design through Implementation

1. In the Flow Navigator, click Generate Bitstream.
The No implementation Results Available dialog box opens.

2. Click Yes.
The Launch Runs dialog box opens.

3. Make the appropriate choices and click OK.
Bitstream generation can take several minutes to complete. Once it finishes,
the Bitstream Generation Completed dialog box asks you to select what to do
next.
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4. Keep the default selection of Open Implemented Design and click OK.
5. Verify that all timing constraints have been met by looking at the Timing -
Design Timing Summary window, as shown in the following figure.

Timing ? 03X
a = 4 Design Timing Summary
»

General Information

Timer Settings Setup Hold Pulse Width

Design Timing Summary Worst Negative Slack (WNS). 0.994 ns Worst Hold Slack (WHS). 0.016ns Worst Pulse Width Slack (WPWS). 0.000ns

Clock Summary (23 Total Megative Slack (TNS). 0.000 ns Total Hold Slack (THS): 0.000 ns Total Pulse Width Negative Slack (TPWS). 0.000 ns

Methodology Summary (27 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0

Gheck Timing (12 Total Number of Endpoinis: 64541 Total Number of Endpoints: 64523 Total Number of Endpoints 25011

Intra-Clock Paths
Inter-Clock Paths
Other Path Groups
User Ignored Paths

All user specified timing constraints are met.

Unconstrained Paths

Timing Summary - impl_1 (saved)

Note: The timing summary for your design might be slightly different.

Step 8: Export the Design to the Vitis software platform

ﬁ IMPORTANT! For the usb driver to install, you must power on and connect
the board to the host PC before launching the Vitis software platform.
Next, open the design and export to the Vitis software platform.

1. From the Vivado File menu, select File > Export > Export Hardware. The
Export Hardware Platform dialog box opens.

2. Click Next.

3. Select the Include bitstream option using the radio button in the Output view
and click Next.
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Export Hardware Platform X
Qutput
Setthe platform propedies to inform downstream tools of the intended use of the target platform’s hardware design.

() Pre-synthesis
* This platform includes a hardware specification for downstream software tools.

(®) Include bitstream
~ This platform includes the complete hardware implementation and bitstream, in addition to the hardware specification for
software tools.

4. Leave the XSA file name field at its default value and click Next. (The
following figure shows Windows-specific settings.)
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m Export Hardware Platform

Files

Enter the name of your hardware platform file, and the directory where the XSA file will be stored.

XSAfile name: mbv_subsystem_wrapper

Export to:

-]

The XSA will be written to: mbv_subsystem_wrapper.xsa

| Finish |

| Cancel |
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5. Click Finish. This will export the hardware XSA File in the project directory.

Export Hardware Platform
AM D n Exporting Hardware Platform
VIVE d 0 O 4 new fixed hardware platform named 'mby_subsystem_wrapper' will be written as
ML Edition mbv_subsystem_wrapperxsa’.

© The platform will include a postimplementation model, including a bitstream description, describing
the hardware for downstream software tools.

To export the platform, click Finish.

/_\ .

6. To launch the Vitis software platform, select Tools > Launch Vitis IDE. The
Eclipse Launcher dialog box opens.

Step 9: Create a “Platform Component”
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The Vitis software platform launches in a separate window.

Welcome to the Vitis Unified IDE

Get Started

1. Select Open Workspace and select an new folder for the desired Workspace
location, such as C:\Projects\Vitis_Workspaces\microblaze-system (Windows-
specific).

2. Select File > New Component > Platform or under Embedded
Development click Create Platform Component.

Go

Welcome to the Vitis Unified IDE

Get Started
aaaaa

u

&u
u
[

iwIP TCP Perf Client

Show Welcome page on startup.

E® ®oAo

3. Click Next.
4. In the Platform Creation Flow window, select the Hardware Design option and
Click Browse to open the Select Hardware Design (XSA) window. Navigate to
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the directory where the XSA file was created in Vivado and click Open.

Create Platform Compaonent

Name and Location > Flow > OS and Processor >

Select Platform Creation Flow

Create a platform component by selecting the hardware design and add software domains.

@ Hardware Design (:} Existing Platform

Hardware Design (X5A) TG Pesorabinss s by mby_subsystem... v

Browse
For Implementation

> Advanced Options

| Cancel

5. Click Next.
6. In the Operating System and Processor window, select the standalone for the

operating sytem and microblaze_riscv_0 for the processor.

Create Platform Component
Name and Location > Flow > OS and Processor > Summary
Select Operating System and Processor

Specify the details for the initial domain to be added to the platform component. More domains can be added and user can edit the domain settings later by opening

the platform editor.

Operating system: | standalone

Processor: | microblaze_riscv_0

( Cancel )

7. Click Next.
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8. Review the Platform Component Creation Summary and click Finish.

Create Platform Component

Name and Location > Flow > OSand Processor > Summary

Summary

The following new Platform component will be created

Name platform

Workspace Propers U S0 Ll Do obiaie « slbsySter e
‘Component directory Propeors LGS0 Lab Porecr ODBIe « WSy ST s\ plariorm
Operating system standalone

Processor microblaze_riscv_0

@ Note: A domain with selected operating systemn and processor will be added to the platform. The platform can be medified later to add new domains or change settings.

Step 10: Create a “Peripheral Test” Application

1. Select File > New Component > From Examples or under Get Started click
Examples.

Ol Fle Edit Selection View Go Terminal Help Vitis

PO A 2N Wi

Welcome to the Vitis Unified IDE

Get Started HLS Development Embedded Development

© Open Workspace
Cre: e Create Platform Component

& Examples Tutorials Embedded Application
IwiP UDP Perf Client

User Guide
WP UDP Perf Server igrate classic IDE worksp

PO D OO B

Online Resources

Documentation
Videos
Memory Tests Forums

OpenAMP echo-test Feedback

a
a
a
a

OpenAMP matrix multiplication Demo.

»

OpenAMP RPC Demo

»

ripheral Tests

»

uthentication App.

»

Srec_baotloader

»

COPOO DD

nqMP PMU Firmwiare
e 7] Show Wekome page onsart up

ILS Introductory Examples
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2. Select Peripheral Tests.

C1 Fle Edit Selecton View Go Terminal Help Vitis

DN Wetcome *| @ peripherai Tests X

Peripheral Tests

Simple t

)
IP Echo Se
Hierarchical name ~ pe:
IwIP TCP Per
IwIP TCP Per
IwIP UDP Perf Client

IWIP UDP Perf Server

AMP Demo

Linux Empty Application

WP Echo Server

[ R e R Y

WP TCP Perf Client

IWIP TCP Perf Server

a

1P UDP Perf Client

OpenAMP matrix multiplication Demo.

OpenAMP RPC Demo

NQMP PMU Firmware

HLS Introductory Examples

®0A0

3. Click on Create Application Component from Template.

Create Application Compenent - Peripheral Tests

Name and Location > Hardware >

Name and Location

Choose a name for your component and specify a directory where component data files will be stored

Component location - WOk npe @3 e NEIe e Browse

Component will be created at EAFaiseiien Watapeosssiorabises sy peripheral_tests

4. Click Next.
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5. In the Platform page, select the previously created platform.

Create Application Component - Peripheral Tests

Name and Location > Hardware > Domain >

Select Platform

Platforms supporting the selected example from your repositories. To create a new platform, use "File - New Component -* Platform™

fo

VENDOR PATH

— pesttreti e - -tor ~.Workspaces\microblaze-system\platform\export\platform

© platform Embedded ailimecom  ..roblaze-system\platform\export\platform\platform.xpfm

| Cancel )

6. Click Next.
7. In the Domain page leave all the fields at their default values and click Next.

Create Application Component - Peripheral Tests

Name and Location > Hardware » Domain > Summary

Select Domain

Choose a domain from the available domains in the platform

Name Details

standalone_microblaze_riscv_0
Name standalone_microblaze_riscu_0

+ create new...

Display Name standalone_microblaze_riscw_0

o5 standalone

Processor microblaze_riscv 0

Cancel )
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8. Review the Summary and click Finish.

Create Application Component - Peripheral Tests

Name and Location > Hardware > Domain > Summary

Summary

The following new application component will be created

Name peripheral_tests

Workspace Pr gty UGSE0 | ab T SbiaIe « sbSySter wws

Component directory PropoasUGEM Lk Pewcroblsse v subsysterm'ses'peripheral_tests
Platform platform

Domain standalone_microblaze_riscv 0 {OS:standalone, Processormicroblaze_risov 0)

) ( Fnish )

9. Anew peripheral tests application is created. If the testperiph.c file is
not already open, select MICROBLAZE-V-SYSTEM/peripheral_tests
[Application]/Sources/src/testperiph.c, and double-click to open the source
file. Modify the source file by inserting a while statement at approximately line
18. Press Ctrl + S to save the file.

a. In line 18, add while(1) above the curly brace as shown in the following
figure.

10. To build the application select peripheral_tests under Flow > Component
and click on Build. Click OK on the pop-up window to build the associated
platform.
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~ FLOW ¥ A

Component ® peripheral_tests v | gs&

47 Build o

11. Wait for the application to finish compiling.

Step 11: Execute the Software Application on a SP701 Board

ﬁIMPORTANT! Make sure that you have connected the target board to the
host computer and it is turned on.

1. To start the session, click on the Run icon under Flow > Component
[peripheral_tests] > Run.

v FLOW ¥ A

Component B peripheral_tests A &‘}

&7 Build &
> Run
3 Debug

2. The Debug perspective window opens, if the testperiph.c file is not already
open, select ..Isrcltestperiph.c, and double-click to open the source file.

File

1n12,Col1 CRF UTFS Spocesis € O B
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1. Configure your terminal program (e.g., TeraTerm, Putty) to connect to the
SP701 Serial Port with the settings shown below.
o Baud rate = 9600
o Data bits =8
o Stop bits = 1
o Flow control = None
o Parity = None

Step 12: Connect to Vivado Logic Analyzer
Connect to the SP701 board using the Vivado Logic Analyzer.

1. In the Vivado IDE session, from the Program and Debug drop-down list of the
Vivado Flow Navigator, select Open Hardware Manager.
2. In the Hardware Manager window, click Open target > Open New Target.

HARDWARE MAMAGER - unconnected

@ No hardware target is open. Open target

Hardware

The Open New Hardware Target dialog box opens, shown in the following

figure.
Open Mew Hardware Target x
AM D n Open Hardware Target
- This wizard will guide you through connecting to a hardware target.
Vivado
ML Edition To connectto a remote hardware target, provide the host name and IP port of the remaote machine on which the
instance of a \Vivado Hardware Server is running.
3. Click Next.
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4. On the Hardware Server Settings page, ensure that the Connect to field is set
to Local server (target is on local machine) as shown in the following figure,
and click Next.

Open Mew Hardware Target X

Hardware Server Settings

Select local or remote hardware server, then configure the host name and port settings. Use Local server if the target is attached to the
local machine; otherwise, use Remote server.

Connectto: | Local server (targetis on local machine) -

Click Mext to launch and/or connectto the hw_server (port 3121) application on the local machine.

oy
(3]
\‘_J/

5. On the Select Hardware Target page, click Next.
6. Ensure that all the settings are correct on the Open Hardware Target
Summary dialog box and click Finish.

Note: You can also use the Auto Connect option to connect to the target hardware.

Step 13: Set the Logic to Processor Cross- Trigger

When the Vivado Hardware Session successfully connects to the SP701 board, you
see the information shown in the following figure:

Hardware 7 O &1 X
aQa = ] > » N L
Mame Status
I localhost (1 Connected
B 7 xilino_tcfXilin/1281038a087 A (1 Open
8 xc7s100_0(2) Programmed
XADC
hwe_ila_1 I f t t L Idle
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1. Select the Settings - hw_ila_1 tab and keep the Trigger Mode Settings with
the default value:
1. Set Trigger mode to BASIC_ONLY.
1. Under Capture Mode Settings, ensure that Trigger position in window is
set to 512.

1. Click on the (+) sign in the Trigger Setup window to add the slot 0 :
microblaze riscv_© axi_periph_Me@ _AXI : AWVALID signal from the Add
Probes window.

2. In the Trigger Setup window, for slot_0 :
microblaze riscv_0_axi_periph_Mee_AXI : AWVALID signal, ensure that
the Operator field is set to ==, the Radix field to [B] (Binary) and the Value
field to 1 (logical one).

This essentially sets up the ILA to trigger when the awvalid transitions to a
value of 1.

Trigger Setup - hw_ila_1 Capture Setup - hw_ila_1
Q + o,
MName Operator Radix Value Part Comparator Usage

slot_0: microblaze_riscv_0_axi_periph_MOO_AX] . AWVALID == A= o1 ~  probel3[0]  1of1

3. Click the Run Trigger button to ‘arm’ the ILA in the Status - hw_ila_1 window.
The ILA immediately triggers as the application software is continuously
performing a write to the GPIO thereby toggling the
net_slot_©\_axi_awvalid signal, which causes the ILA to trigger. The ILA in
turn, toggles the TRIG_OUT signal, which signals the processor to stop code
execution.

Conclusion

In this tutorial, you:
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« Stitched together a design in the Vivado IP integrator

» Took the design through implementation and bitstream generation

« Exported the hardware to Vitis

» Created and modified application code that runs on a Standalone Operating
System

» Modified the linker script so that the code executes from the DDR3 memory

 Verified cross-trigger functionality between the MicroBlaze processor
executing code and the design logic

Lab Files

The Tcl script 1ab_riscv_mb.tcl is included with the design files to perform all the
tasks in Vivado. The Vitis software platform operations must be done in the Vitis
GUI. You will need to modify the Tcl script to match the desired project path and
project name on your machine.
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